Version 1.0.0
Language EN

Release 1.0.0-rc.1

Upgrading (Important)

There is no automated upgrade path from version 0.8.x to 1.0.0. There were incompatible changes to the database that will require an advanced migration utility. We plan to publish this utility, with instructions, on or before November 16th.

Notable Features

Breaking Changes

This list is currently being compiled. Please check back soon.

Breaking Yaml Changes

There were significant, breaking changes to the yaml configuration format in this release. Please note, however, 1.0.0 is capable of processing yaml files in the legacy 0.8.x yaml format (with the exception of matrices). If you encounter a yaml file that works with 0.8.x and does not work with 1.0.0 please let us know.

Closed Issues

This list is currently being compiled. Please check back soon.

Known Issues

At this time we are aware of one confirmed regression. Drone is not currently able to process GitHub Deployment webhooks. This only impacts Deployment webhooks, and does not otherwise impact deployment capabilities.

On This Page:

Getting Help

Mailing List
Search for information in the mailing list archives, or post a question.
Chat Support
Real-time chat support from maintainers and community members.